Перейти к содержанию

Структура программы

После запуска программы откроется окно программы, которое имеет следующую структуру:

  • Заголовок окна - отображает наименование программы и базы данных, с которой Вы работаете;
  • Строка меню - содержит группы выпадающих меню, которые необходимы для управления программой;
  • Панель инструментов - содержит кнопки для быстрого доступа к некоторым функциям программы;
  • Панель инструментов справочника - содержит кнопки для быстрого доступа к некоторым справочникам программы;
  • Рабочая область - служит для открытия вложенных окон, которые необходимы для внесения сведений в базу данных;
  • Статус-строка - показывает текущее действие, которое выполняет программа и результат его выполнения.

image alt center

Строка меню

Строка меню содержит группы выпадающих меню, которые необходимы для управления программой.

image alt center

Меню "Файл" включает в себя следующие пункты:

  • "Создать..." (Ctrl+N) - позволяет создать новую базу данных;
  • "Открыть..." (Ctrl+O) - позволяет открыть ранее созданную базу данных;
  • "Закрыть" - позволяет закрыть активное окно в рабочей области;
  • "Сохранить как..." - позволяет сохранить базу данных с новым именем и/или в другом каталоге;
  • "Скопировать на съемный диск" - позволяет скопировать базу данных на съемный диск (флеш-накопитель);
  • "Восстановить со съемного диска" - позволяет восстановить базу данных со съемного диска (флеш-накопителя);
  • "Печать..." (Ctrl+P) - позволяет распечатать справочники или документы;
  • "Выход" - выйти из программы.

image alt center


Меню "Правка" включает в себя стандартные команды работы с программой: "Вырезать" (Ctrl+X), "Копировать" (Ctrl+C) и "Вставить" (Ctrl+V). Эти пункты доступны только при редактировании содержимого полей ввода.

Также через меню открывается "Журнал изменений" (F3).

Неактивные команды "Отменить назначение занятий" (Alt+Bksp) и "Вернуть назначение занятия" (F4) при выполнении действий в программе становятся активными и позволяют отменить последнее действие/вернуть отмененное действие.

image alt center


Меню "Вид" включает в себя следующие пункты:

  • "Планшет занятий" - открыть планшет занятий;
  • "Панель инструментов" - позволяет вывести на экран стандартную панель инструментов или панель инструментов "Справочники";
  • "Статус строка" - выводит на экран статус-строку;
  • "Обновить" (F5) - позволяет обновить любое активное вложенное окно программы;

    Примечание

    Вложенные окна при их активизации обновляются автоматически, но при возникновении непредвиденных ситуаций можно использовать данную команду, чтобы снова прочитать содержимое базы данных и вывести данные на экран.

  • "Параметры" - открыть параметры программы.

image alt center


Меню "Справочники" включает в себя пункты, которые открывают справочники, необходимые для внесения сведений:

image alt center


Меню "Отчеты" включает в себя пункты, которые позволяют открыть отчеты, предусмотренные в программе для вывода их на печать:

image alt center


Меню "Сервис" включает в себя следующие пункты:

  • "Калькулятор" - позволяет открыть калькулятор из набора стандартных программ Windows;
  • "Календарь" - позволяет открыть календарь;
  • "Сжать базу данных" - позволяет сжать базу данных;
  • "Архивировать базу данных" - позволяет сформировать архив с базой данных;
  • "Вложить в письмо базу данных" - позволяет заархивировать и вложить базу данных в письмо в программе, которая используется для отправки электронной почты по умолчанию;
  • "Индивидуальные параметры" - информация о составе аттестационной комиссии;
  • "Параметры..." - позволяет настроить программу;
  • "Обновить программу" - позволяет проверить наличие обновлений;
  • "Деактивировать программу" - позволяет деактивировать программу;

image alt center


Меню "Окно" включает в себя пункты для упорядочивания вложенных окон в рабочей области, а также пункт "Новое окно", которое открывает планшет занятий:

image alt center


Меню "Справка" включает в себя следующие пункты:

  • "Руководство пользователя" (F1) - открывает руководство пользователя;
  • "Совет дня..." - открывает окно с подсказками, советами или интересными фактами по работе в программе;
  • "О программе" - открывает окно со сведениями о программе.

image alt center


Если открыт "Планшет занятий", доступно дополнительное меню "Действия", которое включает в себя следующие пункты:

  • "Назначить / заменить занятие";
  • "Заменить преподавателя...";
  • "Заменить аудиторию...";
  • "Заменить тему...";
  • "Отменить занятие";
  • "Запретить занятие";
  • "Журнал занятий";
  • "Информация".

image alt center

Стандартная панель инструментов

Панель инструментов содержит кнопки для быстрого доступа к следующим функциям программы:

image alt center

  • image - открыть планшет занятий;
  • image - создать новую базу данных;
  • image - открыть ранее созданную базу данных;
  • image - сохранить базу данных под другим именем и/или в другом каталоге;
  • image - открыть форму печати справочника или документа;
  • image - отменить назначение занятия;
  • image - вернуть назначение занятие;
  • image - открыть журнал изменений;
  • image - показать/скрыть панель инструментов справочника;
  • image - открыть справочник "Нагрузка";
  • image - открыть отчет выполнения нагрузки;
  • image - открыть параметры публикации веб-страниц расписания;
  • image - открыть окно выборки занятий;
  • image - обновить текущее окно;
  • image - проверить наличие обновлений программы;
  • image - открыть руководство пользователя.

Панель инструментов "Справочники"

Панель инструментов "Справочники" содержит кнопки для быстрого доступа к следующим справочникам:

image alt center

Панель инструментов внутри справочников

Помимо панели инструментов у каждого справочника есть своя дополнительная панель инструментов. Панель инструментов справочника предназначена для работы непосредственно со справочником.

Примечание

В качестве примера приведена панель инструментов справочника "Нагрузка".

Набор кнопок в других справочниках может отличатся.

image alt center

  • image - добавить новую строку;
  • image - изменить выделенную строку;
  • image - копировать сведения из выделенной строки и добавить новую;
  • image - удалить выделенную строку;
  • image - импортировать сведения в справочник;
  • image - копировать сведения для других групп, подгрупп, специальностей;
  • image - связать или разорвать нагрузку;
  • image - удалить всю нагрузку;
  • image - открыть анализ нагрузки;
  • image - открыть журнал занятий;
  • image - поле имени, к которому относятся записи (например, группа) и год обучения группы.
Вверх